Page 118 of 120 FirstFirst ... 1868108116117118119120 LastLast
Results 1,171 to 1,180 of 1198

Thread: Ferrari 288 GTO - BUILD - Project

  1. #1171
    Senior Member Don's Avatar
    Join Date
    Oct 2002
    Location
    Victoria, BC Canada
    Posts
    3,472
    Thanks Dave;

    I think it will be a matter of figuring out how different the wiring harnesses are between the two years and see if it is within my capabilities to correct. Means pulling the cradle though so I can get full access to the plugs and wiring loom and trace wires properly. Will finish cleaning and painting the engine bay at that time as well.

    More to come this week hopefully
    Don
    308 Ferrari replica
    Prova Countach 5000QV

  2. #1172
    Senior Member Don's Avatar
    Join Date
    Oct 2002
    Location
    Victoria, BC Canada
    Posts
    3,472
    Ok so tracing wires and I have a plan..... I got a new harness plug to match up the wires for the injectors on the engine harness. The '96 has sequential firing so 6 control wires, 1 each going to each injector on the engine side but because the '91-'93 ecm has batch firing, I only have two injector control wires coming from the ecm. The two wires both fire simultaneously so my pan is: Take the injector wires from the current engine harness and move them to the new plug. On the engine bay harness side I will take my two control wires and wire them into three injector wires each. I will control each side by one control wire and then I will move the fused 10 amp circuit that goes to the other wires in the injectors one each to each side as well. I will then have 3 injectors wired to one control wire and one fused power wire from the Fiero fuse block, INJ 1 and INJ 2 10 amp fuses. Looks like, from what I can tell so far, the rest of the wires match up but a few more to trace out.

    Looking good. More to come
    308 Ferrari replica
    Prova Countach 5000QV

  3. #1173
    Senior Member Don's Avatar
    Join Date
    Oct 2002
    Location
    Victoria, BC Canada
    Posts
    3,472
    Quick update. Got the injectors wired up to the ECM. Wired 1,3,5 to D3 and 2,4,6 to D9 and used the INJ2 fused wire from the fuse block to power the injectors, I was able to put all injector wires into a new, separate connector so they are separate. I have been tracing the remaining wires off the 96 engine harness today and have it all detailed in a spreadsheet but now with all 4 wiring diagrams (91/93, 94/95, 96 and Fiero where needed) I am getting confused on the harness side so going to go trace the ecm side wires on the car to see how it was working out. I can map the 91-93 to the 94-95 and confirm colours and pin outs from the ecm and then translate that to the 96 engine harness. My plan anyway. We will have to see how successful that plan will be tomorrow.

    Have I mentioned before how much I enjoy wiring?.........
    308 Ferrari replica
    Prova Countach 5000QV

  4. #1174
    Senior Member Don's Avatar
    Join Date
    Oct 2002
    Location
    Victoria, BC Canada
    Posts
    3,472
    Latest update. I know WAY more about this wiring harness than I wanted to. I have mapped and reconfigured pretty much EVERY wire on the engine harness. It appears that the 96+ engine harness moved every wire from the grey plug used in 91-95 harness to the black plug on the '96 engine and added new sensors to the grey plug. Also moved all injector wires to the third, new plug introduced in 96+. Well, I have them all mapped and written down. Will be updating the spreadsheet drawing I have so I can share here for others that want to go down this wild and wonderful adventure. I am still a bit confused on the EGR wiring but will ask some wiring experts over on Pennock's on that one as the earlier versions use 4 wires three of which enable the relays in the egr and the 96+ uses 5 wires and what appears to be only two wires than engage the relays...... I will try one more time to get the 96 egr wired up and if it doesn't work, I will move on.

    On other updates in the harness, I pretty much think I have everything wired to where it should run now. Possibly not well when cold if it is expecting the EGR to work. I turned the engine over and no fire so checked a plug and no fuel still. My next round will be to take an injector wire off and engage the injector by power to one side and ground to the other. Should make the injector engage and I should hear the click. If that is the case, then look into power to the pink (again) and if that works then I am not getting the signal from D3/D9.

    That goes into ecm troubleshooting. I have an ALDL connector to usb connector coming and downloaded TunerPro to see what the settings and codes are in the ECM and carry on from there. I am wondering if a sensor is not being read so no start as I am 99% sure the theft control has been mapped out of teh ECM flash. Work taking up the first couple days of this week so hope to get out there either tonight or tomorrow night to keep going.

    Enjoy
    Don

    Wiring 101.......

    308 Ferrari replica
    Prova Countach 5000QV

  5. #1175
    Senior Member TRcrazy's Avatar
    Join Date
    Oct 2003
    Location
    New York
    Posts
    484
    Keep going Don! Iím sure youíll get it running and driving soon. Thanks for posting so we can all learn from your efforts . - Vinny

  6. #1176
    Senior Member Don's Avatar
    Join Date
    Oct 2002
    Location
    Victoria, BC Canada
    Posts
    3,472
    My current status of the wiring and troubleshooting. I am still not getting the injectors to fire.


    I have confirmed the pink wire going to the injectors has 12V in run. I have confirmed that when putting power and ground to the injectors, they will fire. The three I can get to anyway. I just don't seem to have the signal coming from D3/D9 on the 91-93 ECM. That tells me I am looking to the ECM for next steps.


    I have ordered an ALDL connector and hopefully it gets here soon. I tried shorting out the A and B terminals on the ALDL with a troubleshooting light but no lights or codes showed. Not saying there are no codes, just didn't come through with the trouble light.


    One point I found in the troubleshooting was B10 in the ECM diagrams says power at all times but I don't get power on B10 until I put into Run?


    Are there other sensors or triggers inside the 91-93 that I need to check out so I can get power to the injectors? Any other items anyone can think of that will help push me forward and troubleshoot the ECM before I get my ALDL cable? I will be using TunerPro as well to get the settings and codes out as a starting point.


    Any help appreciated.
    Don
    308 Ferrari replica
    Prova Countach 5000QV

  7. #1177
    Senior Member
    Join Date
    Feb 2013
    Location
    Annapolis Valley Nova Scotia
    Posts
    216
    Quote Originally Posted by Don View Post
    I just don't seem to have the signal coming from D3/D9 on the 91-93 ECM. That tells me I am looking to the ECM for next steps.

    I tried shorting out the A and B terminals on the ALDL with a troubleshooting light but no lights or codes showed. Not saying there are no codes, just didn't come through with the trouble light.
    It's not clear what you're doing is the right way to check for codes. If you're connecting a test light between ALDL terminals A&B and expecting it to flash codes, it doesn't work that way. You have to connect A&B together, then check for 12V pulses (either with a multimeter or by connecting one lead from a 12V test light to the SES light output terminal on the ECM, and grounding the other lead). If you don't get code 12 flashing at least three times on the SES light output terminal, your ECM is fried.

  8. #1178
    Senior Member Don's Avatar
    Join Date
    Oct 2002
    Location
    Victoria, BC Canada
    Posts
    3,472
    And there you have part of it. Thanks very much Dave. Yes I was doing it all wrong..... I will check this way in the morning. I am also going to check all my ECM grounds are also connected correctly as the injectors are grounded through the ecm so I want to confirm I get grounded correctly through the ECM.

    More to check.

    Thanks
    Don
    308 Ferrari replica
    Prova Countach 5000QV

  9. #1179
    I have ran into a couple times with no injector pulse to be map sensor related either wrong map or pinned incorrectly. May be a place to start
    .

  10. #1180
    Senior Member
    Join Date
    Dec 2014
    Location
    Near Niagara Falls ON
    Posts
    118
    hi Don; didn't realize you were using a 91-93 ecm. If yours somehow turns out to be faulty I have one in my garage you're welcome to. Came from a manual trans Z34. Never been opened nor the plugs removed. Can ship it out, I can't use it for what I am doing. LMK. I'm near Niagara Falls, ON.

    GP

Similar Threads

  1. A Little Project I am Working On BUILD
    By slipondajimmy in forum Build Diaries
    Replies: 36
    Last Post: 03-07-2012, 04:26 PM
  2. 512TR BUILD Project
    By bodyman in forum Build Diaries
    Replies: 18
    Last Post: 10-12-2011, 03:57 PM
  3. help needed for design and build project
    By rossicars in forum General Kitcar Chat
    Replies: 0
    Last Post: 10-26-2006, 06:48 PM
  4. What to build next? Or whats your next dream project?
    By StormBringer in forum General Kitcar Chat
    Replies: 16
    Last Post: 04-25-2005, 02:26 AM
  5. Project build site available
    By racing_trends in forum General Kitcar Chat
    Replies: 0
    Last Post: 12-02-2002, 02:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •