Results 1 to 5 of 5

Thread: Toyota celica radio no power

  1. #1
    Senior Member
    Join Date
    Apr 2015
    Location
    Houston,Tx,USA
    Posts
    181

    Toyota celica radio no power

    So guys, what happend was, i install a aftermarket back up camera to my pioneer avic 5000nex headunit, for the camera power, 12v go to the reverse tail light, and ground go to frame, it was working for couple minute, then when i put the headunit resting on the shift knob, it just turn off, now i got nothing, radio fuse not blown, i even replace the 7.5 multi fuse, what could be the problem?, i check the voltage for the radio 12v, only read less then 1 volt.
    Current Project: Ferrari F430 White
    Donor Car: 2000 Silver Toyota Celica GT(Automatic)

  2. #2
    Senior Member
    Join Date
    Oct 2009
    Posts
    1,847
    run a power wire direct from battery to radio

    You might have shorted something and damaged the thin power wire

  3. #3
    Senior Member
    Join Date
    Apr 2015
    Location
    Houston,Tx,USA
    Posts
    181
    What best way to fix it?

  4. #4
    Senior Member
    Join Date
    Oct 2009
    Posts
    1,847
    If it's shorted you'll need a new radio
    If it just needs a power wire run a new power wire

    Run a test by hooking it directly to positive and negative battery terminals and see if it works
    Last edited by cutlass442; 12-30-2015 at 09:22 PM.

  5. #5
    Senior Member
    Join Date
    Apr 2015
    Location
    Houston,Tx,USA
    Posts
    181
    I'll try it tomorow, hopefully not the radio, i have no warranty on it, and it cost me 375.
    Current Project: Ferrari F430 White
    Donor Car: 2000 Silver Toyota Celica GT(Automatic)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •